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CHAPTER 2

How Does the Player Work?

In this chapter you'll learn how to operate Windows Media Player 7. You’ll
see how to play files, use the buttons to navigate, change the settings, use the
menus, and switch to different views and modes. You’ll also be shown how
to find files on the Internet, copy music from CDs, and use playlists.

Playing a file in only three steps

Playing music or video on the Player is a simple 1-2-3 process:
1. Go to the Now Playing view.
2. Pick a song from a playlist and click the song title.
3. Then click the Play button to begin playing.

The three'steps to playing a song are shown below in more detail.

Step 1: Start with the full mode Player

When you start Windows Media Player 7 for the first time, and you are con-
nected to the Internet, you should see the full mode Player in the Media
Guide view. Figure 2.1a shows a typical Media Guide view.
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Figure 2.1a - Full mode Player in Media Guide view with Internet connection.
The Media Guide is a Web site that gives you a doorway into the world of

audio and video on the Internet. The contents change nearly every day, giv-
ing you new audio and video selections, current entertainment news, and free

downloads.

If you are not connected to the Internet, you’ll see a screen similar to Figure
2.1b.
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Chapter 2: How Does the Player Work?

You can now get started using Windows Media Player. Click Now Playing on
the left side of the full mode Player. You should see a view similar to Figure

2.2. '

Beautiful Way

Figure 2.2 — Windows Media Player in ﬁll mode in the Now Playing view.

If you don’t see something like Figure 2.2, you’re probably looking at a skin.
A skin may have been loaded by the last person to use the Player; you won’t
be able to see the Now Playing view when a skin is running. If you are view-
ing a skin, you will want to return to the full mode of Windows Media Player.

Windows Media Player comes in two modes: full mode and compact mode.
The compact mode is used to display skins, and the-full mode displays the
standard Player. To return to full mode from any skin, right-click anywhere
on the skin and then click Return to Full Mode on the shortcut menu that

appears.
The full mode has several different views it can display. Right now, all you
want to do is play a file, so click Now-Playing at the left side of the full

mode Player. You should now see something that looks close to Figure 2.2.
You probably will have a different visualization or a different playlist loaded

on your computer, but you're ready to start.

27
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Step 2: Choose a song

There are several ways to choose a file to play, but the easiest way is to use a
playlist. Playlists will be covered in greater detail later in this chapter, but to

‘ _ get you started, use the playlist that should be visible on the right side of the
! Now Playing view.

Figure 2.3 shows a Now Playing view with a playlist named “All Audio” that
contains all the songs that the Player has information about. The third song,
“Laure”, is selected and playing. You can double-click any item in the
playlist to start playing that item. | '

Figure 2.3 — A playlist with more than one item,

You can learn more about using playlists later in this chapter. There are other

ways to choose audio and video files as well, and they will also be covered
in this chapter. ;

Step 3: Click Play

Now that you’ve selected a song title, click the Play button. It looks like an
arrow that is pointing to the right. You can see it in Figure 2.4.
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Chapter 2; How Does the Player Work?

Figure 2.4 — The Play button of the full mode Player.

When you click the Play button, two things happen. The music starts playing
and the button changes. The button now looks like Figure 2.5.

Figure 2.5 — The Pause button of the full mode Player.

This new button is the Pause button. Any time you want to stop the Player,
just click the Pause button. That will stop the music playing and change the
Pause button back to a Play button.

Using the navigation buttons

Windows Media Player has several other buttons you can use to enhance
your playing experience. The following buttons are always at the bottom of
the window in the full mode Player and are listed here from left to right:

o Play/Pause

¢ Stop

e Seek

e Mute

¢ Volume
s Previous

o Fast Reverse

¢ Fast Forward

o Next

e Switch to compact mode

If you hover over a button with the mouse pointer, the name of the button
will appear.

29
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‘ Figure 2.6 shows the navigation buttons for the full mode Player. These but-
@ tons are also called transport buttons and use symbols that are common to the
electronic industry for controlling tape recorders, VCRs, and CD players.
You’ll often see the same button symbols in skins, but because every artist
designs skins his own way, and the artwork varies widely, you won’t neces-
sarily find all the same buttons in each skin, or the buttons may not be in the
same order.

Figure 2.6 — Navigation buttons.

Here is a brief explanation of each button.

Play/Pause
This button toggles back and forth between two states: Play and Pause.

Play starts the selected music or video playing, and Pause pauses it.
Clicking Play from a paused state will start the program playing from the
same position it was paused at.

Stop
This button stops a currently playing program. If you click Play after
clicking Stop, the program will start over at the beginning.

Seek
This is the long bar that extends above the other buttons. The Seek bar

shows the current position in the file. If you click and drag the tiny box,
you can change the current position in the file to anywhere you want.
The left end of the Seek bar represents the beginning of the file, and the
right end represents the end of the file. So the midpoint of the bar
represents the midpoint of the file, regardless of its length.

Mute
‘Click this to mute the sound of the currently playing file. Click it again to

return the sound to its previous volume.

’ Volume '
This is a short triangular bar with a box above it. Click and drag the box
left or right to increase or decrease the volume of the sound.
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Previous ,
Click this to go to the previous title in a playlist.

Fast Reverse
Click this to move the current seek position of the file backward. Click it

again to start playing from the new seek position. This button only works
for video files that use the Windows Media video file format.

Fast Forward
Click this to move the current seek position of the file forward. Click it

again to start playing from the new seek position. This button only works
for video files that use the Windows Media video file format.

Next
Click this to go to the next title in the playlist.

Switch to compact modé
Use this to change the Player display to compact mode. This will change
the user interface to the default skin or the last skin you selected.

Watching visualizations

At the bottom of the left side of the Now Playing pane, you’ll see two but-
tons. Click these to change visualization presets. These buttons are shown in

Figure 2.7.

Figure 2.7 — Previous visualization and Next visualization preset buttons.

Visualizations draw moving shapes and colors on the screen that rise and fall
in time to the beat and tone of the music. Several visnalizations are included
with Windows Media Player, and more are available from the Windows Me-
dia Player Visualizations Gallery. Click Download Visualizations on the
Tools menu to go there.

Each visualization has several presets. Each preset gives a different “flavor”
or “twist” to the visualization; for example, one preset might make all the
colors soft pastels and another preset would make them vivid primary colors.
You can change visualizations and presets by clicking the Previous visual-
ization and Next visualization buttons. The visualization and preset names
are displayed to the right of the buttons, with the visualization name first, and
the preset name following, separated by a colon.
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You won’t see a visualization if you’re playing a video, because they both
use the same display pane.

Changing other settings

There’s one other button that can be useful when playing audio and video. At
the top of the full mode Windows Media Player, just to the right of center,
you’ll see the Show Equalizer & Settings button that looks like Figure 2.8.

Figure 2.8 - Show/Hide Equalizer & Settings in Now Playing button.

Clicking this button will show a new pane in the Now Playing area that is
below the visualization/video pane. This pane covers several settings. To

L move to a new setting, click the Previous setting or Next setting button.

] These buttons are shown in Figure 2.9.

|
|
| |
; I § Figure 2.9 — Previous setting and Next setting buttons.
!

| .
The following settings are accessed from this pane by clicking the Previous
j s setting and Next setting buttons:

I ¢ SRS WOW Effects
¢ Graphic Equalizer

e Video Settings
e Windows Media Information
o Captions

Here is a brief explanation of each setting.

SRS WOW Effects settings

This pane allows you to adjust the SRS WOW settings. SRS is a type of sur-
round sound that makes your audio sound more lifelike and three-dimen-
sional. You can see the SRS WOW Effects pane in Figure 2.10.

ke .
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Figure 2.10 — SRS WOW Effects pane.

On the right is the logo for SRS. Click it to find out more about SRS. On the

left are two horizontal sliders that adjust the TruBass and WOW Effect. Be-

tween the two sliders and the SRS logo are two buttons: the top turns SRS on
and off, and the bottom one toggles betwéen various presets.

Here is a brief explanation of each button:

TruBass
Sliding this all the way to the right increases the bass enhancement of the

audio. Sliding to the left decreases it.

WOW Effect
Sliding this to the right increases the perceived height and width of the

audio image.

On/Off
Click this toggle button to turn the SRS WOW Effects on or off.

Speaker Settings :
Click this to toggle through the following speaker settings: normal

speakers, large speakers, and headphones.
Graphic Equalizer settings

This pane allows you to adjust the audio to make it sound exactly the way
you’d like. If you want to boost the bass or cut out high notes, this is the
place to do it. Figure 2.11 shows the Graphic Equalizer pane.

Figuré 2.11 — Graphic Equalizer pane.

On the left you see ten sliders that correspond to ten divisions of the audio
spectrum. Move the leftmost slider up to increase the power of the lowest fre-
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quencies, move it down to reduce them. Similarly, the rightmost slider con-
trols the upper tenth of the spectrum (the highest frequencies). Play with the
sliders to see what sounds good to you.

To the immediate right of the sliders are two buttons. The top one turns the
graphic equalizer on or off. If it is off, the settings are completely “flat,” that
s, no modification is made to the sounds. The bottom button toggles through
several presets that are based on popular styles of music. For example, the
Jazz preset will boost the middle frequencies more than the Acoustic setting,
If you make changes in the Custom preset, those changes will be saved for
the next time you use the Player.

To the right of those two buttons is a final horizontal slider that allows you to
adjust the stereo balance. Move it to the left to increase the apparent volume
of the left channel and to the right to increase the right volume.

Video settings

This pane allows you to adjust the video to make it look the way you like it,
If you want to adjust the brightness or the intensity of the color, this is the
place to do it. Figure 2.12 shows the Video Settings pane.

Figure 212 — Video Settings pane.

On the left side of the pane are four horizontal sliders. They adjust the
Brightness, Contrast, Hue, and Saturation of the video picture. To the right
of these sliders is a button that resets all the sliders to their default (centered)

positions.

Here is a brief explanation of each slider:

5 Brightness * '

e This adjusts the brightness of the video picture. Slide it all the way to the
' left to make the picture completely black and all the way to the right to
i make it completely white. Usually you’ll want it somewhere in between.
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Chapter 2: How Does the Player Work?

Contrast
Use this to sharpen or blur video images. Moving this slider all the way

to the left makes the picture sharper. This effect is sometimes known as
posterization. Moving it to the right makes the image look blurry, as if
everything was photographed in a dense fog or underwater.

Hue
Adjust the hue for basic color changes. Slide it to the left to make

everything more red/purple and to the right for green.

Saturation _ :
This adjusts how much color is shown in the video. Slide the slider all the

way to the left, and only the gray tones are used, with no color at all.
Slide it all the way to the right, and the colors are extremely intense

(saturated).

Windows Media Information

This pane isn’t really a setting, but shows additional information about a par-
ticular item. For example, if you load the Sample Playlist, and open the Win-
dows Media Information pane, you’ll see something like Figure 2.13.

Edwindows ‘r
Pl d ot X .
e, DA L

Figure 2.13 — Windows Media Information pane.

The Windows Media Information pane can display details such as genre and
label, but can also display pictures, links, and other useful information. In
this example, if you click the album cover or the link to the right of it, you’ll
‘be taken to a Web page that gives more details about the artist, album, label,
and so on. For more information on how to create advertising information
such as the kind you see in the Windows Media Information pane, see

Chapter 13.
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Captions

L This pane isn’t really a setting either, but shows captions for video files, See
1 Figure 2.14 for a typical caption file.

Figure 2.14 — Captions pane.

I
'L For more information about captions, see Chapter 13.
n

Using menus

Many of the operations you can perform with buttons can also be done
through menus. The File menu is always available in the full mode view but
is also available in skins that provide menus. Here is a bnef listing of each
menu item and what it does.

File menu

The File menu helps you work with files. The followmg commands are ava11—
able on the File menu:

Open
Use this to load a file, using the standard Windows Open dialog box. The
file you select will be loaded into anew playlist, and the file will start
playing.

Open URL _
Use this to load a file from a Web site or over a network. A URL

g (Uniform Resource Locator) is a path to a file; for example, hztp.//

A internalsite/laure.wma is a URL. You must type a URL that links to an

: audio or video file. If you type a URL to a Web page, you will get an

aiii ' CITOT.

Close
This doesn’t close the Player; it closes the media file that is playing. It
stops the Player and deselects the current item in the current playlist.
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Add to Library
Use this to add a track to the media library. The media library is the
collection of all audio and video that the Player has information about.
When you select this option, you are given three choices: Add Currently
Playing Track, Add File, and Add URL. The first choice is useful when
you want to add the content that is currently playing to the media library.
The second and third choices are similar to the Open and Open URL
commands on the File menu except that instead of playing the file, the
Player just adds it to the media library.

Import Playlist to Library
Use this to import a playlist into the media library. Playlists are Windows
Media metafiles that have an extension of .asx, .wax, .wvX. You can also
import a .m3u file which will automatically be converted to a playlist.

Export Playlist to File
Use this to save a selected playlist in a text file. If you don’t have any
playlists selected (or any playlists at all), the media library will be saved

as a playlist.

Copy to CD
Use this to copy files to a CD. You must have a CD-ROM that is

recordable and a CD drive capable of recording. For more information
about copying files to a CD-ROM, see Chapter 3. You may not see this
menu item if you do not have a recordable CD drive installed on your

computer.
Properties
~ Selecting this will display information about the audio or video that is
currently playing. .

Work Offline
Use this option if you don’t want the Player to go out to the Internet to

gather information about CDs.
Exit
This will shut down Windows Media Player.

" View menu

The View menu helps you see all the different parts of Windows Media Player
and work with visual elements. The following commands are available

through the View menu:
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i Full Mode
This option returns you to the full mode view.

Compact Mode
Use this to change from full mode to a skin. Whatever skin you used last

will be the default skin.

Now Playing Tools
Select this to change how the Now Playing area looks. You can choose to
hide or display the playlist, title, and visualization portions of the pane.
You can also show or hide the following settings: SRS WOW Effects,
Graphic Equalizer, Video, Windows Media Information, and Captions.
Finally, you can also hide or show the resize bars, which are the bars that
separate the sub-panes of the Now Playing area.

Task Bar
The Task Bar menu command provides access to the same features
found on the Task Bar tabs at the left side of the full mode Player. The
following features are provided: Now Playing, Media Guide, CD Audio,
Media Library, Radio Tuner, Portable Device, and Skin Chooser. For
more information about the Task Bar, see the “Changing views in full
mode” section of this chapter,

S L R A e

Visualizations ,
Selecting this option provides a list of the currently loaded visualizations.
Selecting a visualization shows you the presets that are avaijlable for each
visualization.

File Markers
Use this to go to a specific position in a file that has markers. If a file
doesn’t have markers, you can’t select this option. For more information
about file markers, see Chapter 12.

il Statistics

. Selecting this option can show you how well the file is playing. This can
be particularly useful if you want to report problems with files that you
are receiving in real time through the Internet (called streaming). If there
il A are problems, you usually will know, but this option can give you exact
l L answers, such as how many packets are being lost during transmission.

Full Screen
i If you are playing a visualization that supports it, use this option to have
‘ the visualization display over the full screen of your computer. Once in
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full screen, you can return to normal mode by pressing the ALT and
ENTER keys simultaneously.

Refresh
Use this to refresh the page when you are using the Media Guide,

. Portable Device, or Radio Tuner panes. If you think you’re looking at
yesterday’s Web page, you may be right. Some information in these task
panes is cached, that is, stored on your hard disk, depending on the
settings in Internet Explorer or your portable device.

Zoom
This allows you to change the size of a v1deo that is playing. You can
choose to make it fit the screen, or pick a specific percentage of the
original. The percentages are 50%, 100%, and 200%.

Play menu

The Play menu gives you most of the same options that the transport buttons
offer. The following commands are available through the Play menu:

Play/Pause
This starts the music or video program playing, or if it is already playing,
. pauses it. The Player must have at least one item in the media library in
order to play. Playing a paused file starts the file playing at the same
position it was paused at.

Stop
This stops the currently playing program. If you click Play after stopping
 the program, the song or video will start over at the beginning.

Skip Back ‘
This stops the currently playing item in the playlist and plays the
previous item in the same playlist. This corresponds to the Previous
button in the Player buttons at the bottom of the full mode Player. If you
are at the first item in a playlist and you select Skip Back, the last item in
the playlist will be played. ‘

Skip Forward
This stops the currently playing item in the playlist and plays the next
item in the same playlist. This corresponds to the Next button in the

Player buttons at the bottom of the full mode Player. If you are at the last -

item in a playlist and you select Skip Forward, the first-item in the
playlist will be played. :
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Rewind
This rewinds a video in short intervals. You can only rewind videos that
are encoded in Windows Media Format. This corresponds to the Fast
Reverse button in the Player buttons at the bottom of the full mode
Player.

I Fast Forward

il This fast forwards a video in short intervals. You can only fast forward
il videos that are encoded in Windows Media Format. This corresponds to
| the Fast Forward button in the Player buttons at the bottom of the full
mode Player. '

Shuffle
This plays the items in the current playlist in a random order. It does not
change the order of the items in the playlist, only the order in which they
bl are played while the shuffle option is selected.

Repeat :
This repeats the playing of the entire current playlist, not specific items in
a playlist. If you want to repeat only one item, create a new playlist, put
only that item in it, and repeat that playlist.

Volume

This lets you nudge the volume up or down by a small amount, It also
allows you to mute the volume.

Tools menu

The Tools menu is for advanced features of Windows Media Player. The fol-
lowing commands are available through the Tools menu:

Download Visualizations

Select this to go to a Web page that will let you download new
visualizations. -

Search Computer for Media ‘

Use this to search your computer for all audio and video files. The Player
will add the files it finds to your media library and divide them between
the audio and video collections. If you choose the option to search for
WAV and MIDI files, you will add a lot of Windows sound effects that
you may not want to play with the Player; on the other hand, you may
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discover some interesting MIDI files that are hidden away inside your
Windows folder. You can choose to load from local drives, network
drives, all drives, or a specific drive, and even a specific directory. If you
have mapped a network drive to your computer, you can search that
drive as well. For example, if drive X: is mapped to a network drive, you
can search that drive, or directories on that drive.

License Management
If you download music that requires a license, or make copies of CD
tracks, this option specifies where you want to store the licenses on your
computer. You might want to pick a folder that you can find easily so you
can conveniently back up your licenses to another drive or storage
medium. If you pay for a song and the song needs a license to play,
you’ll want to take good care of your licenses. For more information
about licensing, see “Understanding digital rights” in Chapter 3.

Options
This is the option for everything else not covered in other menu items.
The following section, “Options dialog box,” provides more information
about this menu item.

Options dialog box

If you go to the Tools menu and click Options, the Options dialog box is dis-
played. It covers various options you may want to change. The following
tabs are included in the Options dialog box:

Player
- 'This tab lets you set how often you want Windows Media Player to check

for software upgrades (daily, weekly, monthly), whether you want the
Player to automatically download codecs it needs (See Chapter 3 for

- more about codecs.), whether you want the Player to identify itself to
Web sites and download licenses automatically, whether you want the
Player to start up in Media Guide (instead of whatever you mode you
used last time), and whether you want skins to be on top of other
windows. You can also decide whether you want the anchor to be
displayed when using skins. The anchor window is a small window that
appears in the lower right corner of the screen when Windows Media
Player is in compact mode. You can click the anchor window, and then
click Return to Full Mode to return to the full mode of the Player. Most

41
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of the time you’ll want to leave these options the way they were initially
set.

Network _
If you are an advanced networking user, you can use this tab to set

i proxies, ports, and protocols.

f ' CD Audio

T Use this to set up how you will play or record CDs. For playing CDs, you
can choose whether to use digital playback, if your computer supports it,
1. and whether to use error correction. Change these options if you are
having problems playing CDs. For copying music from CDs, you can
select how much compression to use when converting music from CD
format to music file formats. You’ll have to choose between smaller file
sizes and better quality. You can also choose whether to use digital
copying or error correction, and whether to use personal rights
management. Finally, you can choose what folder you want the copied
audio files to be created in. For more information about copying CDs and
digital rights, see Chapter 3.

Portable Device
If you have a portable device, you can use this pane to decide whether to
let the Player convert the music automatically or let you pick a tradeoff
between file size and audio quality. You can also click a button and find
out what devices are supported by Windows Media Player. For more
information about portable devices, see Chapter 5.

Performance
You might want to use this tab if you are having trouble with viewing live
files (streaming). You can tell the Player what network connection you
have, how much buffering to do, whether you want to use hardware
acceleration with video, and how to adjust digital video settings. For
more information about streaming, see. Chapter 4.

Media Library
Use this tab to set access rights to your media library. You can specify
what levels of access you want to grant outside Web sites to read or
modify the media in your library. This involves both security and privacy
issues. This also specifies whether you want Internet music purchases to
be added to your library automatically.
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Visualizations :
If you have installed a visualization that has properties you can change,
go to this tab to change them. For example, the Ambience visualization
will let you set the full-screen size and offscreen buffer size. You can also
use this tab to load a visualization that is stored on your computer but
that is not registered with the Player. Be sure you know the source of any
visualization before loading, and load them from only trusted sites, so
that you can avoid viruses.

Formats
Use this tab to make sure the Player plays the file formats you want it to

play. If another brand of player starts playing a file that you want
Windows Media Player to play, change the file association here, if it is a
file format the Player can play.

Help menu

The Help menu gives you help and information. This menu has the following
three commands:

Help Topics
This command launches the Help file that comes with Windows Media
Player. The Help file covers all the features you need to know about to
use the Player. You can also get the Help file by pressing the F1 key on
your computer at any time while Window Media Player is the active
Window.

Check For Player Upgrades
. Use this command any time you’re curious about upgrades to Windows
Media Player. The Player will do this automatically for you, but you may
want to do it yourself if you've heard news of a new version.

About Windows Media Player
This will display the name, copyright, version number, and product ID of

Windows Media Player.
Compact mode shortcut menu

When Windows Media Player is in compact mode, you can right-click the
skin and get a menu. Each of the commands on the menu corresponds to a
similarly named command on one of the menus of the full mode Player.

43
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Table 2.1 shows the commands on the menu of the compact mode along with

their corresponding full mode menu commands.

Compact mode menu comménd Full mode menu command
Open File menu Open option
Open URL File menu Open URL option
Shuffle Play menu Shuffle option
Repeat Play menu Repeat option
Volume Play menu Volume option
Play/Pause Play menu Play/Pause option
Stop Play menu Stop option
Skip Back Play menu Skip Back option
Skip Forward Play menu Skip Back option
Return to Full Mode Play menu Skip Forward option
Full Screen View menu‘ Full Screen option
Properties File menu Properties option
Stafistics View menu Statistics 6ption
Options Tools menu Options option
Help Help menu Help Topics option
About Ele:;)e?sggoibout Windows Media
| Exit File menu Exit option

Table 2.1 — Menu commands of the compact mode Player.
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Changing views in full mode

The full mode of Windows Media Player has seven views that are accessed
by clicking tabs on the Task Bar, which is on the left side of the window.
Each view gives you a different way to interact with audio and video. Here is
a list of the views:

Now Playing
This view shows a visualization or video on the left pane and a playlist
on the right. You can also display a hidden settings pane to make various
adjustments or see additional information. You’ll spend most of your time

in this view.

Media Guide
This is the default view of the Player and opens up a world of audio and
video through the Internet. You can get daily news of new audio and
video releases, tune in to Internet radio stations, and download tons of
things to see and hear, most of it free! For more help with downloading,
see the “Finding files on the Internet” section in this chapter.

CD Audio
If you have a CD player in your computer, you can play your CD tracks
using Windows Media Player. For more information about using CDs, see
the “Copying music from CDs” section in this chapter. For more
information about creating your own CDs, see Chapter 3.

Media Library
This is where you can organize all your audio and video. You can search

for audio and video files on your computer, create playlists, and change
your Internet radio presets here. For more information about working
with playlists, see the “Using playlists” section of this chapter,

Radio Tuner
Use this feature to search out and sort Internet radio stations. From
around the world or around the block, you can listen to music every hour
of every day and never hear the same thing twice!

- Portable Devices
Use this pane to download music to your Pocket PC or other portable
device. For more information about portable devices, see Chapter 5.
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Skin Chooser
Use this to apply skins that came with your installation. You can also use
this feature to download new skins from the Windows Media Skins
- Gallery Web site. Once you try one skin, you’ll never want to stop! New
skins will be appearing frequently, so check this site often.

Finding files on the Internet

Now that you know how to use the Windows Media Player, you can go out
on the Web and find more music. You can use a browser to do this of course,
but Windows Media Player gives you a special window to the world of music
and video. This window is called the Media Guide. Earlier in this chapter
you saw a typical view of the Media Guide in Figure 2.1a.

The Player will start up with the Media Guide view. You can always get to it
by using the full mode of the Player and clicking Media Guide on the Task
Bar on the left side of the Player. If you don’t want Media Guide to be the
default view, go to the Tools menu and click Options; then click the Player
tab and clear the Start Player in Media Guide check box.

The Media Guide is a window to the WindowsMedia.com Web site. The Me-
dia Guide has hundreds of links to new audio and video files to play and
download, and gives you lots of information about what’s new in the world
of audio and video. You can spend hours and hours exploring the Media
Guide. -

For more information about file formats you can download, see Chapter 3.
For information about seeing and hearing files without waiting to download
them (streaming), see Chapter 4.

Copying music from CDs

If you want to listen to music from different CDs without inserting and re-
moving your CDs all the time, Windows Media Player can save you a lot of
time. All you have to do is copy the CD (or just the tracks you want) onto
your computer, then assemble the tracks into playlists and create your own
customized musical experience.

| Also, you can have the Player compress the files so they won’t take up as
i much room on your hard disk. You can control the amount of compression
i you need. Choosing high compression will create files that won’t sound as
1 good but will take up less space.
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Copying tracks

Copying CD tracks is extremely easy. All you need to do is load a CD into
your CD-ROM drive and start Windows Media Player. When the Player starts,
it loads the CD tracks into a playlist and displays the CD Audio pane of the
full mode Player. Figure 2.15 shows a typical CD Audio pane, which you can
always get to from the full mode view of the Player by clicking the CD Audio
tab of the Task Bar on the left side of the Player.

If you are connected to the Internet, the Player will go out to a database and
get information about each track on the CD, showing you not only track
names and lengths, but artist, genre, style, and so on. On many CDs, you can
even click the Album Details and go to a Web site that contains more infor-
mation about the CD.

After you’ve loaded your CD, all you have to do is decide which tracks you
want to copy to your computer. After you’ve decided, select the check box at
the left of each track to select the tracks you want to copy.
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Figure 2.15 — Audio CD pane.

When you’re ready to copy, just click the red Copy Music button. You’ll see
that the Player starts copying because there is a Copy Status column in the
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I CD Audio playlist, and the status will be displayed: Files that are being cop-
‘ ied will have a percent-copied display; files that will be copied are labeled
i “Pending” and when a file is finished copying, it will be labeled “Copied to
Library” in the status colummn.

Selecting copy options

There are several options you can select that will allow you to change the
way that the Player copies files from a CD to your computer. Click Options
on the Tools menu, and then click the CD Audio tab. You’ll see the following

choices:

Digital playback (under Playback Settings)
This setting only applies to playback, not to copying CDs. If your
computer supports digital playback, select this check box and see how
digital playback sounds. If you don’t select this option, you will not be
able to see visualizations.

Use error correction (under Playback Settings)
This setting only applies to playback, not to copying CDs. If you are
experiencing a lot of errors, selecting this check box may help correct
them during playback. You’ll know you’re getting errors if the audio
sounds as if parts are missing or the video starts jumping around and
missing frames. You can only select this if you have also selected the
Digital playback check box.

Copy music at this quality (under Copying Settings)
Windows Media Player can compress the digital information in the files it
creates so that the files will be smaller. It does this using a variety of
techniques. Depending on the type of music you’re copying, you may or
may not notice the difference. You can choose the amount of
compression with a slider bar. An average music CD can be compressed
from as small as 28 MB to as large as 70 MB. The larger the file, the
better the sound quality.

Digital copying (under Copying Settings)
Select this check box to copy CD tracks to audio files that enable digital

playback. Not all computers and sound cards have digital playback. If

yours do, this is a good option to use, and the sound'doesn’t need to be :
i converted to analog and back to digital. If you’re not sure, try a track f
il both ways and see what you like. ‘
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Use error correction (under Copying Settings)
You can only select this check box if you’ve also selected the Digital
copying option. Use this if your tracks are producing errors. Once again,
if you're not sure whether to use this, try a track both ways and listen to
the results.

Enable Personal Rights Management (under Copying Settings)
If this check box is selected, the files you create will have information
attached to them indicating that they were created on your computer. You
will definitely want to keep this option checked if you want to copy your
files to a portable device such as a Pocket PC; many portable devices will
not play music if you have not licensed the appropriate rights for a
particular file. However, if you keep this option checked, you cannot
play files you have copied on another computer. So if you want to copy
files from your CD and then transfer them to another computer, you
should not select this option. Of course, before copying and transferring,
be sure you have the legal right to do so. The issues of digital rights are
covered in Chapter 3.

Using playlists

A playlist is a convenient way to organize groups of audio and video files.
The term comes from the radio industry and refers to the list of songs that a
disc jockey plays on a particular radio program. ‘ :

You might want to make up playlists for different performers or different
kinds of music or videos. You can shuffle playlists or repeat them endlessly.
This way, you can create a media experience that is continuously entertain-
ing. |

You can see which playlist is playing by looking in the upper-right corner of
the full mode Player. You will see a drop-down list box, which shows the cur-
rent playlist.

Using the Media Library

. The Media Library is the key to understanding playlists. The Media Li-
brary is where you create your playlists. You can get to the Media Library
by choosing the Media Library tab on the Task Bar of the full mode Win-
dows Media Player. Figure 2.16 shows a typical view of the Media Library.
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Figure 2.16 — Media Library.

On the left side of the Media Library you’ll see a tree-like list of all the au-
dio and video that the Player has information about, as well as all playlists
and radio presets. This is set up similar to Microsoft Windows Explorer in
that you click an item on the left and the contents of that item appear on the

right.

'The Media Library is divided into the following sections:
e Audio

e Video

¢ My Playlists

e Radio Tuner Presets

¢ Deleted Items :

Each section is a node in the tree. Figure 2.17 shows the five nodes of the
Media Library. )
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Figure 2.17 — Five nodes of the Media Library.

Figure 2.18 shows the nodes expanded by one level for each node. You can
expand a node to show the items inside it by clicking the plus sign to the left
of the node name. '

Figure 2.18 — Media Library nodes expanded by one level.

You can explore the contents of the Media Library by expanding the nodes.
Any time you click one of the node item names, the contents of that node, if
it is a folder, will be displayed in the right pane of the Media Library.

Understanding the audio collection

The audio collection is the part of the library that keeps track of audio files
on your computer and other audio files that the Player has information about
(for example, files on the Internet).

Adding Audio Files

You can add to the audio collection in several ways:

e (lick the File menu, click Open, and then choose an audio file, ,

¢ (lick the File menu, click Open URL, and then choose an audio file.

e Click the File menu, click Add to Library, and then choose an audio file.
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* Click the File menu, and click Import Playlist to Library (if the playlist
+ has links to audio files in it).

* From the CD Audio task pane, copy a CD track to your computer.

¢ Start an audio file playing by double-clicking it.

 Start an audio file playing by right-clicking it and seIectmg the Play op-
I tion.

Sorting audio files

You can find a file by clicking the Search button at the top of the Media Li-
brary pane.

i The Audio collection is a database of audio files, and like other databases, it

; stores not only the file name and location of audio files, but additional infor-
mation such as artist, album, and genre. This additional information is used
to sort the Audio collection into at least four categories. You can see the cat-
egories by clicking the nodes to the left of the Audio label. Figure 2.19 shows
the four nodes inside the Audio collection.

Figure 2,19 — The four nodes of the audio collection.

" Here is an explanation of each category:

All Audio
This includes a list of all audio that Windows Media Player has
information about.
] Album
This shows a list of all music that is associated with albums. The album
il information can come from a CD, from a playlist, or can be embedded in
the file itself. The Player can get album information about CDs from
Internet database's.
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Artist
You can see a list of all the artists that are associated with the audio files

in the Audio collection.

Genre
If you want to find audio files that have a genre associated with them,

this is the place to look. 7
Understanding the video collection

The video collection uses the same concepts as the audio collection except
that it keeps track of video files. Instead of All Audio, the video collection
will refer to All Clips, Artist becomes Author, and there is no album or genre
equivalent for videos.

Understanding My Playlists

This is a collection of all playlists that the Player has information about.
Playlists are lists that you create of audio and video content.

Creating playlists

Creating playlists couldn’t be simpler. Click the New Playlist button at the
top left of the Media Library and enter the new playlist name.

Adding to playlists
You can add to playlists by doing the following:
1. Create your playlist.

2. Find the audio or video file you want to add. You must open an Audio or Video

collection and select a file from the collection. For example, open the Audio
collection, then open the Artist collection, choose an artist you like, displaying
all the songs by that artist in the right pane.

Select the audio or video file, and add it to the playlist. You can do this in one of
two ways. The easy way is to right-click the file and choose the Add to Playlist
option. You’ll be provided with a list of playlists. Pick one and you’re done.
There’s also an Add to Playlist button at the top of the Media Library pane if
you prefer to click a button.

You can also select the audio or video file and drag it to the playlist in the left
pane. This requires a bit of opening and closing of nodes in the collection, but
after you get used to it, you’ll find that this is a useful way to work with
complicated playlists,
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Deleting and renaming playlists

You can also delete and rename playlists by right-clicking a playlist and
choosing the delete or rename option. Deleted playlists aren’t really deleted,
they are transferred to the Deleted Items part of the Media Library.

Deleting media items and playlists

If you delete an item in the audio or video collection, the item is transferred
to the Deleted Items part of the Media Library. The same is true for deleted
playlists. This is similar to the Recycle Bin in Windows.

Restoring media items and playlists

You can get the file or playlist back by right-clicking it and selecting the Re-
store option. The file or playlist will return to the place you deleted-it from.

Permanently deleting media items and playlists

If you want to permanently erase the media items and playlists you deleted,
I you can reclaim their disk space by right-clicking the Deleted Items node

i and choosing the Empty Deleted Items option. Be careful! After you do this,
it you can’t go back! But at least you're given an option to change your mind
before the media files and playlists are gone forever.

Using the Radio Tuner

The Radio Tuner feature lets you use the Player to listen to Internet radio sta-
tions from around the world. Thousands of stations broadcast audio pro-
4 grams of music, news, and commentary.

- Figure 2.20 shows the Radio Tuner view, which you can get to by clicking
Radio Tuner in the task bar on the left side of the full mode of Windows Me-

dia Player.
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Figure 2.20 — Radio Tuner view in the full mode Player.

The Radio Tuner view has two panes: Station Finder and Presets.

Using Station Finder

The Station Finder can help you tune in to Internet Radio stations. Even
though there are thousands of stations around the globe, you can easily find
one you like with only a few clicks. The contents of the Station Finder are
updated frequently by WindowsMedia.com so that as new stations go on the
air, you can tune in to them right away.

All the stations are listed in a table that sorts them by station name, speed,
frequency, and format or city. You can sort the table rows by clicking the col-
umn heading you want to sort on. Double-click a station listing to start it
playing.

Above the table of radio stations is one or more list boxes. The box on the
left has several categories that you can use to find particular radio stations,
including the following: :

Format
This gives you a set of predefined radio station formats ranging from

Alternative Rock to Classical to News Radio.
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Band
You can choose to search through the AM band or FM band, or choose

Internet-only.

Language
There are several spoken languages to choose from, including Chinese,
English, Latvian, and 20 others.

Location
Countries such as the United States, Finland, Korea, and 30 others are

represented in the table listings with radio stations. If you choose the
United States, you can search by state.

Callsign
If you know the call letters of a radio station, you can find the station by
typing the call letters in the search box. For example, if you type
“CKWW?”, you’ll listen to station CKWW in Detroit, Michigan, that
specializes in big band music.

Frequency
You can tune in to a station by typing the frequency; for example, 88.5
on the FM dial would give you radio station KPLU in the Seattle,

Washington, area.

Keyword _
If a station has a slogan, you can find it with a keyword. For example,
searching for “oldies” will give you several stations to choose from.

Using station presets

There are two default presets that you can use to sort radio stations that you
will want to use often. One is called Featured and has stations that are cur-
rently featured by Windows Media Player. You can’t add stations to Featured.
But you can add radio stations that you want to use frequently to My Presets.

You can create your own preset categories by élicking the Edit button above
the Presets list.

Working with radio stations in the Media Library

All presets created in the Radio Tuner are automatically copied to the Media
‘ i Library in the Radio Tuner Presets category.
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